Mailinglist Archive: opensuse-buildservice (151 mails)

< Previous Next >
Re: [opensuse-buildservice] linking with X11 in OBS
  • From: Roger Oberholtzer <roger@xxxxxx>
  • Date: Mon, 10 Mar 2014 13:45:46 +0100
  • Message-id: <16052162.e0HYi5u1BM@acme>
On Monday, March 10, 2014 01:36:55 PM Marcus Meissner wrote:
On Mon, Mar 10, 2014 at 01:25:48PM +0100, Roger Oberholtzer wrote:
Hi,

I am trying to compile a Tcl/Tk extension that uses X11. I can
successfully
compile it on my local machine (direct - not in a local OBS) and it
compiles just fine. I use the same commands I see in the OBS log. Oddly,
when the application is being linked in OBS, it complains about some
missing functions that I really think should be resolved. Especially
since the same command works on my system.

The order on the linker line is important, libraries need to come rightmost.

That was my first thought. I did not really want to fiddle with the configure
stuff to change this unless there was no other option. But I guess I will.

I am still curious why the EXACT same (cut and paste from OBS Log-> command
line) command works on my system. The order of the libs was the same.

--
Yours sincerely,

Roger Oberholtzer

Ramböll RST / Systems

Office: Int +46 10-615 60 20
Mobile: Int +46 70-815 1696
roger.oberholtzer@xxxxxxxxxx
________________________________________

Ramböll Sverige AB
Krukmakargatan 21
P.O. Box 17009
SE-104 62 Stockholm, Sweden
www.rambollrst.se
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups