Mailinglist Archive: opensuse-buildservice (193 mails)

< Previous Next >
[opensuse-buildservice] Dependency conflicts in Ubuntu
  • From: Rolf Krahl <rolf@xxxxxxxxxxx>
  • Date: Fri, 31 Jan 2014 09:07:28 +0100
  • Message-id: <3067800.1Iki2QL5K7@rinzewind>
Hi,

I have a package in my personal project at the openSUSE Build Service
that I build for several distributions. For Ubuntu I get
"unresolvable" errors:

"have choice for libjpeg-dev needed by libhdf5-serial-dev:
libjpeg-turbo8-dev libjpeg-dev, have choice for libjpeg-dev needed
by libhdf4-dev: libjpeg-turbo8-dev libjpeg-dev".

For Ubuntu 12.10 I additionally get even more:

"have choice for libblas3gf | libblas.so.3gf | libatlas3gf-base
needed by python-numpy: libblas3 libblas3gf, have choice for
liblapack3gf | liblapack.so.3gf | libatlas3gf-base needed by
python-numpy: liblapack3 liblapack3gf".

For RPM based distributions, I solve such kind of conflicts by adding
appropriate entries in the Project Config, so I currently have there
for instance:

%if 0%{?centos_version} || 0%{?rhel_version}
Prefer: atlas
%endif

%if 0%{?fedora_version} == 18
Prefer: texlive-simplecv
%endif

Does something similar also work for DEB based distributions? How
would a corresponding entries for Ubuntu look like?

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups