Mailinglist Archive: opensuse-buildservice (193 mails)

< Previous Next >
Re: [opensuse-buildservice] Build time resolver fails after newer package version was added to repo

On Wednesday 2014-01-29 14:35, Martin Weber wrote:

on my private instance, I created a project to host 3rd-party binary
rpms to build against.
One of my packages has a 'Build-Requires: foo = 4.1' and could be
properly built.
After I added package foo-5.0 to the 3rd-party-hosting project, my
packages is unresolvable now: 'nothing provides foo = 4.1'
Does the resolver only take the newest version into account by design or
is this a problem with the foo rpm?

Repositories are most-significant, and after that, package version.
This seems to be by design, and to support multiple concurrent package
versions, they need a different package name.
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References