Mailinglist Archive: opensuse-buildservice (193 mails)

< Previous Next >
[opensuse-buildservice] Dependencies supplied by subproject found for some repos, not for others
  • From: Edgar Aichinger <edgar.aichinger@xxxxxx>
  • Date: Thu, 30 Jan 2014 12:11:47 +0100
  • Message-id: <7176149.uJEVm7foe8@edhp>
Hello,

I have a hard time figuring out what causes this, and how to resolve it:

In my home project https://build.opensuse.org/project/monitor/home:edogawa I'm
building packages that depend on packages from another project from OBS,
home:rncbc.

So I branched those I need to a subproject of mine, and they build without
errors for the target repos I need. The subproject got added to my project's
meta config, for every target repo, too. Surprisingly I get unresolvable
dependencies, but only for some target repos though. qmidiarp cannot find
liblo-devel >= 0.26 (branches:home:rncbc has 0.27), and synthclone shows
missing liblilv-0-0 and a few others that the respective -devel packages (from
BuildRequires:) depend on.

What am I missing?

Thanks, Edgar
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups