Mailinglist Archive: opensuse-buildservice (193 mails)

< Previous Next >
[opensuse-buildservice] Dep resolution in libreoffice broken when adding Requires(pre): %{name}-%{version}
  • From: Tomáš Chvátal <tchvatal@xxxxxxx>
  • Date: Tue, 28 Jan 2014 21:46:17 +0100
  • Message-id: <2657058.v80fZYZWpv@mosquito>
Hi,

as per summary in libreoffice spec the lang packages are expanded from macro.
For some unrelated stuff I need to have dep in post over the package itself so
I added it to the spec the above and it now fails with following error localy
and is unresolvable in OBS:

buildinfo is broken... it says:


│··································
unresolvable: nothing provides \

The change is only this but it can be of course contained only for that
requires(pre) line.

https://build.opensuse.org/package/rdiff/LibreOffice:Factory/libreoffice?linkrev=base&rev=97

I am not exactly sure what is wrong, but given that fedora people can use
something similar with rpmbuild i would not deem the spec approach as really
broken.

Cheers

Tom
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >