Mailinglist Archive: opensuse-buildservice (193 mails)

< Previous Next >
Re: [opensuse-buildservice] ARM build failures due to missing kernel-obs-build
  • From: Guillaume Gardet <guillaume.gardet@xxxxxxx>
  • Date: Mon, 27 Jan 2014 18:02:17 +0100
  • Message-id: <52E69119.70302@free.fr>

Le 27/01/2014 17:32, Adrian Schröter a écrit :
On Montag, 27. Januar 2014, 17:18:40 wrote Guillaume Gardet:
Le 27/01/2014 17:10, Adrian Schröter a écrit :
On Montag, 27. Januar 2014, 16:32:48 wrote Guillaume Gardet:
Hi,

on a private OBS instance, I get lots of ARM build failures due to the
following error:
"getbinaries: missing packages: kernel-obs-build"

Some packages are building fine others are in failed state due to this
error.

Is there anything I can do other than trigger a rebuild?
Either it is broken or it should work.

On which archs and projects do you see this?
armv7, native build.

kernel-obs-build is the kernel to be used within KVM. So, for
some armv7 archs it should be an arm kernel, for all arm archs
using qemu, it should be an x86_64 kernel.

It might be that we lack an export filter rule for the later case.

I saw it on Factory and 13.1.

Maybe a sync problem between build.o.o and private OBS instance?
We may have no kernel for nativ armv7 yet.

yes, maybe due to changed project names. You can try to ignore the rule
by adding

VMinstall: !kernel-obs-build

to your instance project.


It did the trick. Thanks.

Note that 12.3 was building fine without it. Strange.

Guillaume

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups