Mailinglist Archive: opensuse-buildservice (148 mails)

< Previous Next >
Re: [opensuse-buildservice] new OBS ups and downs
  • From: Hans-Peter Jansen <hpj@xxxxxxxxx>
  • Date: Wed, 25 Sep 2013 00:16:35 +0200
  • Message-id: <3184631.nEvKmjFLEM@xrated>
Dear Adrian, Michael and co,

this issue is still nagging.

Overall problem: a certain test of a certain package fails spuriously for
random builds.

The test does nothing else than deleting a file, that was created before.
It fails, since for some reason, the file doesn't exist.

I tried to trigger this issue locally, but even by building this project a
hundred times doesn't trigger the failure.

I tend to believe, that some filesystem synchronization issue of certain build
hosts is the reason for this..

Since it is fairly good reproducible with this package, one kind soul might
look into it. I've checked the test, and I don't believe, the test is
responsible for that behavior - wouldn't it trigger locally than, too?

If this *is* some strange build host glitch, than this might be a good
opportunity to examine it. It may happen in other scenarios without noticing..

Cheers,
Pete

On Donnerstag, 12. September 2013 03:04:16 Hans-Peter Jansen wrote:

While at it, you might want to look into:

https://build.opensuse.org/package/live_build_log/home:frispete:python/pytho
n-zdaemon/openSUSE_12.1/i586

This is a strange biest: the test code just creates a file and tests for it
later on. This is the only failing instance after a full package rebuild,
which looks much better than before. Two or three weeks ago, OBS managed
to fail 2/3 builds of this project. I didn't observe this anywhere else.
It might be related to the type of host, where the build happens, now that
we have two of them.

Sorry for not reporting this earlier, but customer/project needs always take
precedence.



--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >