Mailinglist Archive: opensuse-buildservice (170 mails)

< Previous Next >
Re: [opensuse-buildservice] How update /srv/obs/repos?
  • From: Guillaume Gardet <guillaume.gardet@xxxxxxx>
  • Date: Tue, 02 Jul 2013 16:57:22 +0200
  • Message-id: <51D2EA52.1010105@free.fr>

Le 02/07/2013 16:00, Dominique Leuenberger a.k.a. Dimstar a écrit :

Quoting Guillaume Gardet <guillaume.gardet@xxxxxxx>:

Le 02/07/2013 15:35, Dominique Leuenberger a.k.a. Dimstar a écrit :

Quoting "Dominique Leuenberger a.k.a. Dimstar" <dimstar@xxxxxxxxxxxx>:

Quoting Guillaume Gardet <guillaume.gardet@xxxxxxx>:

Hi,

Le 02/07/2013 12:27, Guillaume Gardet a écrit :
Hi,

On my local OBS instance, it seems that /srv/obs/repos/* folders are not very
well updated (repodata contains references to only one package whereas there
are more than 25 in arch folder. Trigger a rebuild of packages does not help.

Any idea why?

Maybe publisher.log could help:
********************************************************************************
Tue Jul 2 12:54:15 2013 publishing multimedia:ARM/openSUSE_12.3_Ports
+ armv7hl/lame-3.99.5-1003.1.armv7hl.rpm
+ armv7hl/lame-doc-3.99.5-1003.1.armv7hl.rpm
+ armv7hl/lame-mp3rtp-3.99.5-1003.1.armv7hl.rpm
+ armv7hl/libmad-devel-0.15.1b-7.1.armv7hl.rpm
+ armv7hl/libmad0-0.15.1b-7.1.armv7hl.rpm
+ armv7hl/libmp3lame-devel-3.99.5-1003.1.armv7hl.rpm
+ armv7hl/libmp3lame0-3.99.5-1003.1.armv7hl.rpm
+ armv7hl/libmpeg2-0-0.5.1-4.1.armv7hl.rpm
+ armv7hl/libmpeg2-devel-0.5.1-4.1.armv7hl.rpm
+ armv7hl/mpeg2dec-0.5.1-4.1.armv7hl.rpm
+ src/lame-3.99.5-1003.1.src.rpm
+ src/libmad0-0.15.1b-7.1.src.rpm
+ src/libmpeg2-0-0.5.1-4.1.src.rpm
fetched 0 patterns
running createrepo
Worker 0: Traceback (most recent call last):
Worker 0: File "/usr/share/createrepo/worker.py", line 99, in <module>
Worker 0: main(sys.argv[1:])
Worker 0: File "/usr/share/createrepo/worker.py", line 87, in main
Worker 0: globalopts.get('clog_limit', None)))
Worker 0: File "/usr/lib/python2.7/site-packages/yum/packages.py", line 1392,
in xml_dump_other_metadata
Worker 0: msg += "%s\n</package>\n" %
misc.to_unicode(self._dump_changelog(clog_limit))
Worker 0: File "/usr/lib/python2.7/site-packages/yum/packages.py", line 1339,
in _dump_changelog
Worker 0: clogs = self.changelog[:clog_limit]
Worker 0: TypeError: slice indices must be integers or None or have an
__index__ method
syncing database (19 ops)

That looks similar to something I had once on my bot.. the only way around it
was for me to downgrade createrepo from what is offered there to the version
from 12.2...

there seem to be some descriptions that kill the process...

Addon info here: if you grab the VideoLAN package tree and run repocreate 0.99
from openSUSE 12.3 over it, you see the same behavior. repocreate 0.98 (I think
that was the version in 12.2) works fine.

createrepo is 0.9.9-2.1.2 for 12.2 and 0.9.9-4.1.1 for 12.3.
It was 12.1 which used 0.9.8.
I will give it a try.

ups... then that only means I had this issue much longer ago :) Sorry for
misleading you on that one.

Thanks Dominique.
I reverted createrepo to 0.9.8 and it works fine.

it seems that --changelog-limit option gives problems with 0.9.9
Just try to run createrepo 0.9.9 on a folder with some RPM with and without the
--changelog-limit option.

It is very annoying, any createrepo guru on the list to help to fix it?


Guillaume


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups