Mailinglist Archive: opensuse-buildservice (170 mails)

< Previous Next >
Re: [opensuse-buildservice] How update /srv/obs/repos?

Quoting Guillaume Gardet <guillaume.gardet@xxxxxxx>:

Le 02/07/2013 15:06, Adrian Schröter a écrit :
Am Dienstag, 2. Juli 2013, 14:58:28 schrieb Guillaume Gardet:
Le 02/07/2013 14:44, Guillaume Gardet a écrit :
Le 02/07/2013 14:18, Adrian Schröter a écrit :
Am Dienstag, 2. Juli 2013, 14:02:25 schrieb Guillaume Gardet:

Le 02/07/2013 12:27, Guillaume Gardet a écrit :

On my local OBS instance, it seems that /srv/obs/repos/* folders are
very well updated (repodata contains references to only one package
whereas there are more than 25 in arch folder. Trigger a rebuild of
packages does not help.

Any idea why?
Maybe publisher.log could help:
**** **** Tue Jul 2 12:54:15 2013 publishing
multimedia:ARM/openSUSE_12.3_Ports +

+ armv7hl/lame-doc-3.99.5-1003.1.armv7hl.rpm
+ armv7hl/lame-mp3rtp-3.99.5-1003.1.armv7hl.rpm
+ armv7hl/libmad-devel-0.15.1b-7.1.armv7hl.rpm
+ armv7hl/libmad0-0.15.1b-7.1.armv7hl.rpm
+ armv7hl/libmp3lame-devel-3.99.5-1003.1.armv7hl.rpm
+ armv7hl/libmp3lame0-3.99.5-1003.1.armv7hl.rpm
+ armv7hl/libmpeg2-0-0.5.1-4.1.armv7hl.rpm
+ armv7hl/libmpeg2-devel-0.5.1-4.1.armv7hl.rpm
+ armv7hl/mpeg2dec-0.5.1-4.1.armv7hl.rpm
+ src/lame-3.99.5-1003.1.src.rpm
+ src/libmad0-0.15.1b-7.1.src.rpm
+ src/libmpeg2-0-0.5.1-4.1.src.rpm
fetched 0 patterns
running createrepo

Worker 0: Traceback (most recent call last):
Worker 0: File "/usr/share/createrepo/", line 99, in <module>
Worker 0: main(sys.argv[1:])
Worker 0: File "/usr/share/createrepo/", line 87, in main
Worker 0: globalopts.get('clog_limit', None)))
Worker 0: File "/usr/lib/python2.7/site-packages/yum/",
1392, in xml_dump_other_metadata Worker 0: msg += "%s\n</package>\n"
misc.to_unicode(self._dump_changelog(clog_limit)) Worker 0: File
"/usr/lib/python2.7/site-packages/yum/", line 1339, in
_dump_changelog Worker 0: clogs = self.changelog[:clog_limit]
Worker 0: TypeError: slice indices must be integers or None or have an
__index__ method syncing database (19 ops)
**** ****

Only the first package is visible, using yast or zypper.
According to the log, createrepo seems to have some troubles with
(except the first one).

Any idea how to fix that?
which createrepo and yum packages do you use? the ones from OBS:Server:*
Yes, the ones from OBS:Server:2.4 for openSUSE 12.3 i586:
* createrepo 0.9.9-4.1.1
* yum 3.4.3-4.1.1
Sorry, but it is not from OBS:Server:2.4 but from repo OSS because
createrepo and yum are not available at OBS:Server:2.4 (disabled)
hm, should work in general, at least our test cases are working with it.

However, try to remove the repodata and repocache directories. Broken
data there might be the cause.

Tried and still the same thing... Only the first package is shown.
Anything else to try (even ugly workaround)?

As stated in my earlier mail: downgrade to repocreate from openSUSE 12.2.

To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups