Mailinglist Archive: opensuse-buildservice (170 mails)

< Previous Next >
Re: [opensuse-buildservice] How update /srv/obs/repos?
  • From: Guillaume Gardet <guillaume.gardet@xxxxxxx>
  • Date: Tue, 02 Jul 2013 14:02:25 +0200
  • Message-id: <51D2C151.2000906@free.fr>
Hi,

Le 02/07/2013 12:27, Guillaume Gardet a écrit :
Hi,

On my local OBS instance, it seems that /srv/obs/repos/* folders are not very
well updated (repodata contains references to only one package whereas there
are more than 25 in arch folder. Trigger a rebuild of packages does not help.

Any idea why?

Maybe publisher.log could help:
********************************************************************************
Tue Jul 2 12:54:15 2013 publishing multimedia:ARM/openSUSE_12.3_Ports
+ armv7hl/lame-3.99.5-1003.1.armv7hl.rpm
+ armv7hl/lame-doc-3.99.5-1003.1.armv7hl.rpm
+ armv7hl/lame-mp3rtp-3.99.5-1003.1.armv7hl.rpm
+ armv7hl/libmad-devel-0.15.1b-7.1.armv7hl.rpm
+ armv7hl/libmad0-0.15.1b-7.1.armv7hl.rpm
+ armv7hl/libmp3lame-devel-3.99.5-1003.1.armv7hl.rpm
+ armv7hl/libmp3lame0-3.99.5-1003.1.armv7hl.rpm
+ armv7hl/libmpeg2-0-0.5.1-4.1.armv7hl.rpm
+ armv7hl/libmpeg2-devel-0.5.1-4.1.armv7hl.rpm
+ armv7hl/mpeg2dec-0.5.1-4.1.armv7hl.rpm
+ src/lame-3.99.5-1003.1.src.rpm
+ src/libmad0-0.15.1b-7.1.src.rpm
+ src/libmpeg2-0-0.5.1-4.1.src.rpm
fetched 0 patterns
running createrepo
Worker 0: Traceback (most recent call last):
Worker 0: File "/usr/share/createrepo/worker.py", line 99, in <module>
Worker 0: main(sys.argv[1:])
Worker 0: File "/usr/share/createrepo/worker.py", line 87, in main
Worker 0: globalopts.get('clog_limit', None)))
Worker 0: File "/usr/lib/python2.7/site-packages/yum/packages.py", line 1392,
in xml_dump_other_metadata
Worker 0: msg += "%s\n</package>\n" %
misc.to_unicode(self._dump_changelog(clog_limit))
Worker 0: File "/usr/lib/python2.7/site-packages/yum/packages.py", line 1339,
in _dump_changelog
Worker 0: clogs = self.changelog[:clog_limit]
Worker 0: TypeError: slice indices must be integers or None or have an
__index__ method
syncing database (19 ops)
********************************************************************************

Only the first package is visible, using yast or zypper.
According to the log, createrepo seems to have some troubles with packages
(except the first one).

Any idea how to fix that?

Guillaume

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
References