Mailinglist Archive: opensuse-buildservice (247 mails)

< Previous Next >
Re: [opensuse-buildservice] false unresolvable in OBS

On Friday 2013-06-28 16:30, Stanislav Brabec wrote:
I need to add conflict to util-linux to conflict with an old version of
coreutils (there is a file conflict of su and kill):
Conflicts: coreutils < 8.21-4

Shouldn't "coreutils < 8.21" be sufficient?

But the util-linux package in home:sbrabec:branches:Base:System builds
just once, and next time it fails:
unresolvable: conflict for provider of util-linux needed by rpm-build,
(provider util-linux conflicts with installed coreutils)

I think that is is not correct and OBS compares Release in a strange
way.

That is indeed really strange, because local builds work,
_and_ local builds usually contact the server for the
list of neededforbuild packages - including the dependency
resolution that goes with it.
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups
References