Mailinglist Archive: opensuse-buildservice (247 mails)

< Previous Next >
Re: [opensuse-buildservice] Still trying to find a solution when a package depends on universe ubuntu repository
  • From: Gianluca Emme <gmaxera@xxxxxxxxx>
  • Date: Fri, 7 Jun 2013 14:33:52 +0200
  • Message-id: <CAPddqDUbw9Pc7bVKO94k-JK_y2+9dQCLKBoDCBuSRHpT=SbsfA@mail.gmail.com>
Dear Martin,
I imported all the sources for rebuilt the packages into the OBS, and
now I get this error on dependencies for the ACE package:

have choice for libjpeg-dev needed by libfox-1.6-dev: libjpeg-dev
libjpeg-turbo8-dev, have choice for libjpeg-dev needed by
libtiff5-dev: libjpeg-dev libjpeg-turbo8-dev

I don't know how to solve them... also because I don't know what this
error means.

Any insights ??

Thanks,
Gianluca.


2013/6/7 Martin Koegler <martin.koegler@xxxxxxxxx>:
On Thu, Jun 06, 2013 at 10:38:50AM +0200, Gianluca Massera wrote:
did you look at the libace source package ??
If yes, how did you arrive at the import number of 3 source packages ??
When I tried the solution 1, I stopped to go further when I realized that I
need to import more that 5 source packages.
So, where did come out your calculation ??


http://archive.ubuntu.com/ubuntu/pool/universe/a/ace/ace_6.0.3+dfsg-0.1.dsc :

Build-Depends: debhelper (>= 9), dpkg-dev (>= 1.16.2), libssl-dev (>=
0.9.7d), libxt-dev (>= 4.3.0), libfltk1.1-dev (>= 1.1.4), libqt4-dev (>=
4.4~rc1-4), tk-dev (>= 8.5), libfox-1.6-dev, zlib1g-dev, libzzip-dev,
liblzo2-dev, docbook-to-man, bzip2, libbz2-dev
Build-Depends-Indep: doxygen, graphviz

doxygen, graphviz are main, as well as debhelper, dpkg-dev, libssl-dev,
libxt-dev, libfltk1.1-dev, libqt4-dev, tk-dev, zlib1g-dev, docbook-to-man,
bzip2, libbz2-dev, liblzo2-dev

Only libfox-1.6-dev, libzzip-dev are universe.


http://archive.ubuntu.com/ubuntu/pool/universe/z/zziplib/zziplib_0.13.56-1.1.dsc
:
Build-Depends: debhelper (>= 7), autotools-dev, pkg-config, zlib1g-dev, python

http://archive.ubuntu.com/ubuntu/pool/universe/f/fox1.6/fox1.6_1.6.45-1ubuntu2.dsc
:
Build-Depends: debhelper (>= 8), libjpeg-dev, libpng-dev, zlib1g-dev,
libx11-dev, libgl1-mesa-dev | libgl-dev, libglu1-mesa-dev | libglu-dev,
libtiff-dev, libcups2-dev, libxcursor-dev, libxft-dev, libxext-dev, libtool,
autoconf, autotools-dev, automake, dh-autoreconf, libfontconfig1-dev,
libfreetype6-dev


And, I disagree with you that the number of built binary packages does not
matter for OBS, because on the mailing list I read a lot of messages about
the waste of space, the waste of resources and so on. And every time, the
administrators instructs users to minimize the use of resources.

It has become a best practice to split even a single files (eg. libraries)
into seperate packages. This results in lots of small packages instead of one
big package.

Regards,
Martin
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups