Mailinglist Archive: opensuse-buildservice (247 mails)

< Previous Next >
[opensuse-buildservice] dependency for ruby gems?
Why does the dependency for ruby gems fail?

Did I miss a step?

Will this fail since I am using the enterprise suse version?

Thanks

Craig

ral-dev02:/home/craig # zypper ar -f
http://download.opensuse.org/repositories/systemsmanagement:/puppet/SLE_11_SP2/
systemsmanagement_puppet
ral-dev02:/home/craig # uname -a
Linux ral-dev02 3.0.13-0.27-default #1 SMP Wed Feb 15 13:33:49 UTC 2012
(d73692b) x86_64 x86_64 x86_64 GNU/Linux
ral-dev02:/home/craig # cat /etc/SuSE-release
SUSE Linux Enterprise Server 11 (x86_64)
VERSION = 11
PATCHLEVEL = 2
ral-dev02:/home/craig # zypper info puppet
Loading repository data...
Reading installed packages...


Information for package puppet:

Repository: systemsmanagement_puppet
Name: puppet
Version: 3.1.1-1.9
Arch: x86_64
Vendor: obs://build.opensuse.org/systemsmanagement
Support Level: unknown
Installed: No
Status: not installed
Installed Size: 2.6 MiB
Summary: A network tool for managing many disparate systems
Description:
Puppet lets you centrally manage every important aspect of your system
using a cross-platform specification language that manages all the
separate elements normally aggregated in different files, like users,
cron jobs, and hosts, along with obviously discrete elements like
packages, services, and files.
ral-dev02:/home/craig # zypper install puppet
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides rubygems needed by
rubygem-ruby-shadow-2.2.0-11.1.x86_64
Solution 1: do not install puppet-3.1.1-1.9.x86_64
Solution 2: break rubygem-ruby-shadow by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c):
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups