Mailinglist Archive: opensuse-buildservice (209 mails)

< Previous Next >
Re: [opensuse-buildservice] xUbuntu nothing provides libace-dev
  • From: Gianluca Emme <gmaxera@xxxxxxxxx>
  • Date: Sat, 18 May 2013 22:26:18 +0200
  • Message-id: <CAPddqDV=+1CdxE4bgHvrag=bJFMT6M=nFs74VNUtUPX1xGBS9g@mail.gmail.com>
Thank you for the suggestion.
But this arise two questions:
- the source is in Debian format 3.0 quilt ; Opensuse build service
support this format for ubuntu builds ??
- on the previous email was told to me that universe repository has
not been added due legal issues ; so, I can be sure do not break some
legal rules importing the sources of a package present in the universe
ubuntu repository ??

Regards,
Gianluca.


2013/5/18 Martin Koegler <martin.koegler@xxxxxxxxx>:
On Fri, May 17, 2013 at 09:48:11AM +0200, Gianluca Emme wrote:
The package is very big and complex, and it's not only a big effort to
import the sources only for the ubuntu builds ... but it is also a bit
silly from the user point of view that for installing my stuff they
requires a different ace library package.
And more important, because libace is used by a lot of other
packages... rebuilding it into my repository can create conflict
problems when the users install my package and another package from
the universe repository both depending on libace :-( :-(

If you import the unmodified sources of the library and all its
dependencies, the built library should be binary compatible.

I need e.g. for home:e9925248:grandorgue the wxWidgets package. So
I added to the project a stub for this packages and all missing predecessors,
which downloads the source via source services from the ubuntu mirrors. Use
for
build is enabled, while publish is disabled - so external users will install
the library from the Ubuntu archive.

Regards,
Martin
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups