Mailinglist Archive: opensuse-buildservice (131 mails)

< Previous Next >
Re: [opensuse-buildservice] SLE 11 SDK Update for rubygem-delayed_job conflicts with obs-api
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Thu, 28 Feb 2013 16:20:44 +0100
  • Message-id: <1859069.enyen8dNWT@scherben>
On Donnerstag, 28. Februar 2013, 16:08:57 wrote Carsten Schoene:
Hello,

i don't know if this is known, the update for rubygem-delayed_job from SLE 11
SDK Updates is kept
back, because obs-api requires a version < 2.0.0
This persists since the ruby upgrades in the last weeks. Is the new version
of rubygem-delayed_job
really not compatible with obs-api?

Yes, we remove OBS from SLE 11 SP3 SDK for that reason.

OBS needs to have fitting rubygem* packages installed, even patch level updates
may
introduce incompabilities. Therefore we ship our own rubygem stack in our
project.

OBS 2.4 will have exact version requires as part of the packages and these will
also be used to run the testsuite during build process.

Means, we will never ever release packages where the test suite is failing :)

bye
adrian

--
Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx

< Previous Next >
References