Mailinglist Archive: opensuse-buildservice (131 mails)

< Previous Next >
Re: [opensuse-buildservice] have choice for postgresql-devel

Am 15.02.13 22:56, schrieb Michael Behrisch:
2013/2/14 Darin Perusich <darin@xxxxxxxxxx>:
postgresql-devel is a dummy package which installs postgresql92-devel
on opensuse > 12.1 with is installs postgresql91. This was done to
maintain compatibility with the old postgres package naming when it
was reworked to add the ability to install multiple versions of
postgres on the same system.

OK, I understand that this might be useful in some cases but does that
mean that every package depending on postgres needs to make the
required version explicit, so should I replace the requires:
postgresql-devel by requires: postgresql92-devel (or even provide
different versions with something like your checkin script)? This
seems to me like a little overkill because it would essentially
duplicate every package depending on postgres. And why does the
dependency checker only fail in the 64bit case?


You could use a "Prefer" setting, which selects the desired version of Postgres.


Best regards,
Michael


--
Johannes Weberhofer
Weberhofer GmbH, Austria, Vienna
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >