Mailinglist Archive: opensuse-buildservice (266 mails)

< Previous Next >
Re: [opensuse-buildservice] Special checks in Factory
Stephan Kulow - 13:09 22.01.13 wrote:
On 22.01.2013 12:10, Michal Hrusecky wrote:
Hi,

I'm trying to reproduce a following bug in OBS:
https://api.opensuse.org/status/bsrequest?id=148204
is complaining about missing dependencies which are in fact subpackages.

Got local instance of obs running, created two projects, let them build
for factory, committed package to one of them and sent sr to the other
one. But I'm receiving no missing packages.

What do I miss in the setup? Some special property I need to set for
project I'm sending to for it to check?

I used OBS appliance with openSUSE:Tools:Unstable repo, so my obs should
be up to date and I can see the code creating missing packages message,
but either it doesn't get triggered or obs uses different version...

Hmm, the check only runs against repos that build against the target
project. So from what you describe you have no such repos, so you should
see no repos at all in the bsrequest status. Is that the case?

Thanks! You are right! I had both projects set to build against Factory.
Now I am able to reproduce it even though it takes ages for some reason.
Now I'll try to play with that.

--
Michal HRUSECKY SUSE LINUX, s.r.o
openSUSE Team Lihovarska 1060/12
PGP 0xFED656F6 19000 Praha 9
mhrusecky[at]suse.cz Czech Republic
http://michal.hrusecky.net http://www.suse.cz
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >