Mailinglist Archive: opensuse-buildservice (266 mails)

< Previous Next >
Re: [opensuse-buildservice] rake db:migrate failures

Quoting Adrian Schröter <adrian@xxxxxxx>:

The OBS 2.3.9x unstable packages seem to come with some issues in the
rake db:migration code.

I can not reproduce these errors when updating from a OBS 2.3.7 appliance to
current :Unstable packages. However, I fixed some migration problems
in this situation
around two weeks ago. Are you sure that you use current pakcages?

this OBS was installed as as 2.2 on openSUSE 12.1 IIRC... then
openSUSE updated to 12.2 and 'forced' to OBS 2.3 for 'admin error for
not checking if everything is compatible'...

The packages are up-to-date:
obs-api-2.3.91_696_g54c4084-1.1.x86_64

Mysql2::Error: Duplicate column name 'kind': ALTER TABLE
`issue_trackers` ADD `kind` ENUM('bugzilla', 'cve', 'fate', 'trac',
'launchpad', 'sourceforge') AFTER `name`

This error looks like this migration did run before, but did not
registered as succeeded.

Would be impossible...

Dominique


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >