Mailinglist Archive: opensuse-buildservice (170 mails)

< Previous Next >
[opensuse-buildservice] Re: Problem building Perl packages for SLES11SP2 with certain build requirements
  • From: Joschi Brauchle <joschi.brauchle@xxxxxx>
  • Date: Wed, 21 Nov 2012 10:15:23 +0100
  • Message-id: <50AC9BAB.6010906@tum.de>
On 11/20/2012 09:47 PM, Andreas Schwab wrote:
Joschi Brauchle <joschi.brauchle@xxxxxx> writes:

On 11/20/2012 06:16 PM, Frank Schreiner wrote:
hi,


Coming back to this problem:

Probably since the last OBS update, my package is now in state
"unresolvable" with the message "conflict for provider of
perl(Module::Build) >= 0.3601, (provider perl-Module-Build is obsoleted
by installed perl)".

have you already tried it this way: ?

# osc meta prjconf -e

and add a line like this:

Prefer: perl-Module-Build


Thanks for the suggestion!

Just tried that, but does not help. Package still stays in "unresolvable"
state.

Perhaps you want "Prefer: -perl-Module-Build" instead.

Unfortunately, this does not help as well... Thanks though!

I am wondering how the 2000+ unresolvable perl packages for SLES11+ will be delt with? Adjusting the prjconf for that repo with a statement for each and every one of these packages seems unfeasible. There should be a more general solution for this problem, right?

< Previous Next >