Mailinglist Archive: opensuse-buildservice (170 mails)

< Previous Next >
[opensuse-buildservice] Re: Slow OBS for the next hour
On Tue 13 Nov 2012 06:28:51 PM CST, Michael Schroeder wrote:

On Tue, Nov 13, 2012 at 11:09:37AM -0600, Malcolm wrote:
It seems it may also affect image builds?

We're seeing the following error for the GNOME 3.6 live image;
https://build.opensuse.org/package/show?package=gnome3.6-live&project=GNOME%3AMedias

"unresolvable: conflict for all providers of sushi needed by
package-lists-openSUSE-GNOME-cd, conflict for all providers of sushi
= 3.6.0 needed by sushi-lang"

Any ideas on what needs tweaking?

Well, the new code detects problems with conflicts/obsoletes, whereas
the old code ignored them (leading to undefined behaviour).

In your case, the sushi package from "GNOME:STABLE:3.6" contains
an "Obsoletes: libsushi-1_0-0 < 3.6.0", but the
"package-lists-openSUSE-GNOME-cd" package requires "libsushi-1_0-0",
which is only provided by "libsushi-1_0-0-0.4.1" from the
openSUSE:12.2 repo. "0.4.1" is less then "3.6.0", thus the conflict.

My guess is that the libsushi library is nowadays provided by
the sushi package (thus the obsoletes), but the package list
was not adapted to this change.

Cheers,
Michael.

Hi
Ahhh, many thanks, missed that when I browsed the package lists :)

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 1 day 15:48, 4 users, load average: 0.14, 0.08, 0.06
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >