Mailinglist Archive: opensuse-buildservice (170 mails)

< Previous Next >
[opensuse-buildservice] local packages do not override global packages

The package ocaml-findlib in devel:languages:ocaml has a BuildRequires:
"camlp4". In the same project ocaml-camlp4-devel (from package ocaml)
provides "campl4".

But this provides is not used, instead the package 'camlp4' from the
main openSUSE_12.1 project is used:

devel:languages:ocaml/ocaml-findlib $ obs r -v
openSUSE_12.1 i586 unresolvable: nothing provides ocaml =
3.12.0-11.1.2 needed by camlp4
nothing provides ocaml(Arg) = 877340141c0babb58b3aaef2f5b70fc9 needed by
camlp4
openSUSE_12.1 x86_64 unresolvable: nothing provides ocaml =
3.12.0-11.1.2 needed by camlp4
nothing provides ocaml(Arg) = 877340141c0babb58b3aaef2f5b70fc9 needed by
camlp4


Is this a bug in the dependency solver?
I reported it via bugzilla, but got no reply up to now:
https://bugzilla.novell.com/show_bug.cgi?id=781120

Olaf
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >