Mailinglist Archive: opensuse-buildservice (178 mails)

< Previous Next >
[opensuse-buildservice] Re: [opensuse-arm] Strange problem when building and ARM image in my own project
On Wed, September 19, 2012 10:26 pm, Alexander Graf wrote:

On 19.09.2012, at 22:21, Joop Boonen wrote:

Hi all,

When I try to build one of these images.
home:worldcitizen:ARM JeOS-ac100
home:worldcitizen:armv7l JeOS-ac100

I get the following error:

[ 508s] Problem: nothing provides /usr/bin/eu-nm needed by
module-init-tools-3.15-6.1.armv7hl
[ 508s] Problem: nothing provides /usr/bin/eu-nm needed by
module-init-tools-3.15-6.1.armv7hl
[ 508s] Problem: netcfg-11.5-13.1.noarch requires aaa_base, but this
requirement cannot be provided
[ 508s] Problem: nothing provides /usr/bin/eu-nm needed by
module-init-tools-3.15-6.1.armv7hl
[ 508s] Problem: nothing provides /usr/bin/tput needed by
aaa_base-12.2-12.1.armv7hl
[ 508s] Problem: nothing provides /usr/bin/tput needed by
aaa_base-12.2-12.1.armv7hl
[ 508s] Problem: xorg-x11-7.6_1-5.1.noarch requires xinit, but this
requirement cannot be provided
[ 508s] Problem: nothing provides /usr/bin/tput needed by
aaa_base-12.2-12.1.armv7hl
[ 508s] Problem: nothing provides /usr/bin/tput needed by
aaa_base-12.2-12.1.armv7hl
[ 508s] Problem: nothing provides /usr/bin/tput needed by
aaa_base-12.2-12.1.armv7hl
[ 508s] Problem: nothing provides /usr/bin/tput needed by
aaa_base-12.2-12.1.armv7hl
[ 508s] Problem: nothing provides /usr/bin/tput needed by
aaa_base-12.2-12.1.armv7hl
[ 508s] Problem: nothing provides /usr/bin/tput needed by
aaa_base-12.2-12.1.armv7hl
[ 508s] Problem: nothing provides /usr/bin/tput needed by
aaa_base-12.2-12.1.armv7hl
[ 508s] Problem: nothing provides /usr/bin/tput needed by
aaa_base-12.2-12.1.armv7hl
[ 508s] Problem: nothing provides /usr/bin/tput needed by
aaa_base-12.2-12.1.armv7hl
[ 508s] Problem: nothing provides /usr/bin/eu-nm needed by
module-init-tools-3.15-6.1.armv7hl
[ 508s] Problem: nothing provides /usr/bin/eu-nm needed by
module-init-tools-3.15-6.1.armv7hl
[ 508s] Problem: nothing provides /usr/bin/tput needed by
aaa_base-12.2-12.1.armv7hl
[ 508s] Problem: nothing provides /usr/bin/tput needed by
aaa_base-12.2-12.1.armv7hl
[ 508s]
[ 508s] Problem: nothing provides /usr/bin/eu-nm needed by
module-init-tools-3.15-6.1.armv7hl
[ 508s] Solution 1: do not install module-init-tools-3.15-6.1.armv7hl
[ 508s] Solution 2: break module-init-tools-3.15-6.1.armv7hl by
ignoring
some of its dependencies


When I remove my own project from the kiwi file I don't see this problem
any more, but then I'm missing some packages.
I wonder what causes this problem.

Is your own project maybe backed by a different project than the one
you're building the appliance for (12.2 vs Factory)?

I don't think so.
This is the meta file for home:worldcitizen:armv7l:

<project name="home:worldcitizen:armv7l">
<title>armv7l</title>
<description>armv7l</description>
<person role="maintainer" userid="worldcitizen"/>
<person role="bugowner" userid="worldcitizen"/>
<build>
<disable arch="i586" repository="openSUSE_Factory"/>
</build>
<useforbuild>
<disable repository="openSUSE_Tumbleweed"/>
<enable repository="openSUSE_Factory"/>
</useforbuild>
<debuginfo>
<enable/>
<disable/>
</debuginfo>
<repository name="images">
<arch>armv7l</arch>
</repository>
<repository rebuild="local" name="openSUSE_Factory" linkedbuild="all">
<path project="openSUSE:Factory:ARM" repository="standard"/>
<arch>i586</arch>
<arch>x86_64</arch>
<arch>armv7l</arch>
</repository>
</project>

This is the meta file for openSUSE:Factory:ARM:

<project name="home:worldcitizen:ARM">
<title>ARM Project with usefull packages that don't exist (yet) in
openSUSE:Factory:ARM</title>
<description></description>
<person role="maintainer" userid="worldcitizen"/>
<person role="bugowner" userid="worldcitizen"/>
<repository name="images">
<arch>armv7l</arch>
</repository>
<repository name="standard">
<path project="openSUSE:Factory:ARM" repository="standard"/>
<arch>armv7l</arch>
</repository>
</project>

I've created openSUSE:Factory:ARM to have fresh minimal project without
any old data.



Alex



Regards,

Joop.

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >