Mailinglist Archive: opensuse-buildservice (140 mails)

< Previous Next >
[opensuse-buildservice] Rebuild time broken in OBS 2.3.1
We are using a local OBS instance (2.3.1 appliance) and the rebuild_time
feature seems to be broken when we upgraded from OBS 2.1.

It worked for us in OBS 2.1

We have the perl-GD rpms installed.

From the webui production.log file, I see these errors:
[ERROR|# 9687] rescue_action: caught Errno::ENOENT: No such file or directory -
/tmp/d20120705-9687-11cssor/rebuild.png
[INFO |# 9687] Rendering template within layouts/application
[INFO |# 9687] Rendering error (400)
[FATAL|# 9687] /!\ FAILSAFE /!\ Thu Jul 05 14:19:02 -0700 2012
Status: 500 Internal Server Error
Mysql::Error: MySQL server has gone away: UPDATE `sessions` SET `data` =
'BAh7CjoKbG9naW4iDW1mZXJuYW5kOhBtb2JpbGVfdmlld0Y6C3Bhc3N3ZCIN\nbWZlcm5hbmQ6EF9jc3JmX3Rva2VuIjFNbGtaYTBybnZ6Ukpka3M4UXUyWmpX\nbEVwb3RDaWpVMnAzK2pRWU4yZ080PSIKZmxhc2hJQzonQWN0aW9uQ29udHJv\nbGxlcjo6Rmxhc2g6OkZsYXNoSGFzaHsABjoKQHVzZWR7AA==\n',
`updated_at` = '2012-07-05 14:19:02' WHERE `id` = 4383

/usr/lib64/ruby/gems/1.8/gems/activerecord-2.3.14/lib/active_record/connection_adapters/abstract_adapter.rb:227:in
`log'

/usr/lib64/ruby/gems/1.8/gems/activerecord-2.3.14/lib/active_record/connection_adapters/mysql_adapter.rb:324:in
`execute'
....


I tried running the rebuild time on the build.opensuse.org site and it does not
produce the rebuild graph, it just states the rebuildtime and the longest paths.
https://build.opensuse.org/project/rebuild_time?arch=x86_64&project=openSUSE%3AFactory&repository=standard

Thanks,

Mal


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups