Mailinglist Archive: opensuse-buildservice (244 mails)

< Previous Next >
Re: [opensuse-buildservice] Deleting .svn directories
2012/6/11 Raymond Wooninck <tittiatcoke@xxxxxxxxx>:
On Monday, June 11, 2012, Ciro Iriarte <cyruspy@xxxxxxxxx> wrote:
Hi, I'm stuck with something that should be pretty simple, I'm trying
to delete .svn directories as part of the build process for a package,
"find" appears to find the directories but while trying to delete them
it gets "No such file or directory".

As this is reaaaaaally basic and is not working, is there any OBS
particularity that would cause this?.

Ref:
https://build.opensuse.org/package/live_build_log?arch=x86_64&package=kannel
&project=home%3Aciriarte%3ASLES-missing&repository=SLE_11_SP2

Hi,

I had a look also at your specfile and noticed two things:

1)      Why do you perform a rm -rf %{buildroot} just before you perform the
installation of your package ?

Hmm, in fact, it was already there in the original spec file, probably
to make sure that no strange files or files from a previous attempt
are there.


2)      As that you already uploaded the source and build them, why do you
want to
remove these .svn directories ? I am sure that they won't cause any issues
during the installation of the package and in the end this wouldn't do
anything. The source tarball is not affected and the .svn directories are not
being installed.

OBS complains with ".svn" is not allowed anymore or something along
the lines... Those get copied in /usr/share/doc/packages.


Regards

Raymond



Regards,

--
Ciro Iriarte
http://cyruspy.wordpress.com
--
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >