Mailinglist Archive: opensuse-buildservice (259 mails)

< Previous Next >
Re: [opensuse-buildservice] expansion error for perl(FCGI) in devel:languages:perl
On 23.05.2012 15:10, Darin Perusich wrote:
Hello All,

I was attempting to update devel:languages:perl/request-tracker this
morning and when running a local build, before committing the changes,
received an "expansion error" for the first time. The build services
tips and tricks says to specify one of the packages as a BuildRequire
and there is, perl(FCGI) which had been resolving to the perl-FCGI
package. The tips and tricks page says to email the list for a long
term fix so here's that email. What needs to be done to work around
this?

expansion error
have choice for perl(FCGI) needed by perl-CGI: perl-FastCGI
perl-FCGI
have choice for perl(FCGI): perl-FastCGI perl-FCGI

One of those packages needs to be dropped - they are duplicating each
other. But I can't find any perl-FastCGI and you didn't say what
repository you're build against.

Perhaps the base distro has perl(FCGI) in a perl-FastCGI. In that case
a Prefer: perl-FCGI in devel:languages:perl's prjconf would be the right
fix.

Greetings, Stephan



--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References