Mailinglist Archive: opensuse-buildservice (214 mails)

< Previous Next >
[opensuse-buildservice] downgrading GCC ?
Greetings all,

I am facing a problem regarding an OBS package and current version of gcc in openSUSE 12.1.

There is a software project called OTB that is built upon ITK. Current version of ITK (4.0) supports gcc 4.6 but OTB is still based on ITK 3.0, and will not upgrade for another year or so.

The problem: ITK 3.0 is not compatible with gcc4.6 when creating python wrappings. So while I try to build OTB-python in OBS I get errors. ITK will not backport fixes to 3.0, I 've tried that...

My only solution left is to use GCC4.5 in openSUSE12.1. Can this happen in OBS? Any ideas?

Regards,
Angelos


--
Angelos Tzotsos
Remote Sensing Laboratory
National Technical University of Athens
http://users.ntua.gr/tzotsos

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >