Mailinglist Archive: opensuse-buildservice (214 mails)

< Previous Next >
Re: [opensuse-buildservice] Re: openSUSE:Tools dropped 11.3 repo already?
  • From: Ludwig Nussel <ludwig.nussel@xxxxxxx>
  • Date: Tue, 14 Feb 2012 09:40:13 +0100
  • Message-id: <4F3A1DED.4070306@suse.de>
Archie Cobbs wrote:
[...]
Why? First, it is worth observing that the very nature of OBS makes it
difficult to pursue that goal. Because in OBS, for any project/package
there is only one spec file - and therefore package version - for ALL
repositories.

In other words, it would be impossible for a maintainer to configure a
package to build foobar-1.2 on openSUSE 11.3 but foobar-2.1 on
openSUSE 12.1.

First and foremost get the package into the distro instead of
building it in some random repo. The whole point of the distro is to
be a collection of packages that work together.

Secondly, you can have different versions of foobar in the same
project by naming the source directories e.g. foobar and a
foobar.openSUSE_xy. Only the latter would be build enabled for
openSUSE xy while the former builds for everything else.

cu
Ludwig

--
(o_ Ludwig Nussel
//\
V_/_ http://www.suse.de/
SUSE LINUX Products GmbH, GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB
16746 (AG Nürnberg)
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups