Mailinglist Archive: opensuse-buildservice (214 mails)

< Previous Next >
Re: [opensuse-buildservice] Question for unsupported packages: Octave, Scilab, Warsow
On Fri, Feb 03, 2012 at 06:29:51PM +0400, Кириллов Александр wrote:


03.02.2012, 13:04, "Petr Gajdos" <pgajdos@xxxxxxx>:
Which same mistakes do you have on mind?

Petr

In octave 3.4.3:
pkg install -forge symbolic
warning: creating installation directory /home/leon/octave
symbols.cc:40:25: fatal error: ginac/ginac.h: Нет такого файла или каталога
compilation terminated.
make: *** [symbols.o] Ошибка 1
'make' returned the following error: make: Вход в каталог
`/tmp/oct-WVSJnW/symbolic/src'
mkoctfile -v -c symbols.cc
g++ -c -DH5_USE_16_API -fPIC -I/usr/include/octave-3.4.3/octave/..
-I/usr/include/octave-3.4.3/octave -fmessage-length=0 -O2 -Wall
-D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables
-fasynchronous-unwind-tables -g symbols.cc -o symbols.o
make: Выход из каталога `/tmp/oct-WVSJnW/symbolic/src'
error: called from `pkg>configure_make' in file
/usr/share/octave/3.4.3/m/pkg/pkg.m near line 1339, column 9
error: called from:
error: /usr/share/octave/3.4.3/m/pkg/pkg.m at line 790, column 5
error: /usr/share/octave/3.4.3/m/pkg/pkg.m at line 361, column 9

You have found the rationale to have octave-forge packaged :-).

wget -O - http://octave.sourceforge.net/symbolic/ 2>&1 | grep "Build
Dependencies"
<tr><td>Build Dependencies:</td><td>ginac-devel</td></tr>

osc cat science octave-forge octave-forge.spec | grep ginac-devel
BuildRequires: libMagick++-devel pcre-devel gsl-devel libginac-devel

Petr

< Previous Next >