Mailinglist Archive: opensuse-buildservice (162 mails)

< Previous Next >
Re: [opensuse-buildservice] about latest openssl update for SLE_11_SP1
On 08/01/12 12:52, Christian wrote:

shouldn't a SLES be "binary compatible" ?
building proftpd and starting will show following:
proftpd[4078]: mod_tls/2.4.3: compiled using OpenSSL version 'OpenSSL
0.9.8h 28 May 2008' headers, but linked to OpenSSL version 'OpenSSL
0.9.8j-fips 07 Jan 2009' library

well, it is binary compatible, but there are apps like proftpd or openssh(!!) that will complain about it, special care has to be taken with ssh, as it calls exit() on a similar (but not identical) situation and refuses to work.

That is. of course, totally wrong. if there is an incompatible ABI change SOVERSION must be incremented, and if new funcs are added, the library should provide symbol versioning.




--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
References