Mailinglist Archive: opensuse-buildservice (145 mails)

< Previous Next >
[opensuse-buildservice] (solved) Web server configuration issues with a single-host installation
Hi,

I have solved the authentication problem by changing all URLs to
localhost and webui_host to 127.0.0.1.
One more thing to edit is
/srv/www/obs/webui/config/environments/production.rb, the FRONTEND_*
settings.

While tweaking, I also updated to obs-api 2.2.96-8.1 from
openSUSE:Tools:Unstable, to find that two important config files for
webui have vanished. The new package tags the files as %ghost, but I
don't think this effect is quite intended.
I have fixed this and submitted request #91226 for the obs-server
source package.

Regards,
Mikhail

2011/11/13 Mikhail Zabaluev <mikhail.zabaluev@xxxxxxxxx>

I am trying to get OBS up and running on a single openSUSE box for my
experimentation.
I have installed openSUSE 12.1 RC2, added the repositories
opensSUSE:Tools and openSUSE:Tools:Unstable, and followed the
installation notes from the obs-api package. The web interface gives
me grief:

OBS Web Interface Error:
Error Details:
Errorcode: 503
Message: Unable to connect to API host. (localhost)

This seems to be caused by an exception reported in
/srv/www/obs/api/log/production.log:

[INFO |# 3133] Processing MainController#index (for 192.168.56.101 at
2011-11-13 02:52:19) [GET]

[FATAL|# 3133] NoMethodError (undefined method `match' for nil:NilClass):
 app/controllers/application_controller.rb:188:in `extract_user'
 passenger (3.0.9)
lib/phusion_passenger/rack/request_handler.rb:96:in `process_request'

It seems to lack something when accessing the information about the
user '_nobody_', which I have bootstrapped in the database; trying to
fix this, I even gave this user confirmed status via the web API
interface, which I can use with the browser after authentication.

To even get to this point, I had to solve some issues which were not
mentioned in the README.SETUP document:

* The apache configuration file /etc/apache2/vhosts.d/obs.conf refers
to 'api' and 'build' as locally resolvable host names. Added them as
aliases in /etc/hosts. A probably better alternative is to change both
URLs to localhost.

* In /srv/www/obs/api/config/options.yml, I needed to enable
allow_anonymous and set webui_host to the host's IP address, otherwise
the API service gives a 401 authentication error to webui, resulting
in the same error display.

* It all may be pretty brittle with regard to the host name. I put
'lynch.private.mikhail-zabaluev.name' as the FQDN for the host in
/etc/hosts, aliased to 'lynch' (and 'api' and 'build', as mentioned
above). Same FQDN in /etc/{HOSTNAME,hostname}. Somehow, all userspace
only retrieves the hostname as 'lynch', which produces warnings about
the server certificate I have generated for the FQDN.
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages