Mailinglist Archive: opensuse-buildservice (175 mails)

< Previous Next >
[opensuse-buildservice] Build Failed for armv8el on OBS light server...
Hi everyone,

I have started a fresh new OBS server based on "OBS light server"
Version = 1.0.1

After correctly setting the proxy configuration in

I can successfully build for Intel with all predefined build target :

But Build for arm failed during during the build environnement configuration ...
Here is some element of the log :

Memory limit set to 5317908KB
Using BUILD_ROOT=/var/cache/obs/worker//root_1
Using BUILD_ARCH=armv8el
obs-server started "build renault_ux.spec" at Fri Oct  7 09:36:09 UTC 2011.
Building Renault_UX for project 'home:xavier' repository  'Remote_MeeGo_1.2' 
arch 'armv8el' srcmd5  '06b3f55fdc2448d2d261d4a087c681a1'
processing specfile /var/cache/obs/worker//root_1/.build-srcdir/renault_ux.spec 
running changelog2spec --target rpm --file 
init_buildsystem --cachedir /var/cache/build --clean --rpmlist 
/var/cache/obs/worker//root_1/.build-srcdir/renault_ux.spec build 
rpmlint-Factory ...
copying qemu
registering binfmt handlers
Warning: mmap_min_addr is != 0. If programs fail at mmap this could be the 
preinstalling file-libs-x86-arm...
preinstalling rpm-libs-x86-arm...
And more preinstalling with no error or warning
preinstalling nss-softokn-freebl...
preinstalling xz-libs...
running bzip2-x86-arm postinstall script
chroot: failed to run command `sh': Exec format error
running tar-x86-arm postinstall script
chroot: failed to run command `sh': Exec format error
running coreutils-x86-arm postinstall script
chroot: failed to run command `sh': Exec format error
running nss-x86-arm postinstall script

It seems that the problem come from binfmt_misc mounting …
I've done the following :
->   ls /proc/sys/fs/binfmt_misc/
The answer gives an is empty answer

->  mount binfmt_misc -t binfmt_misc /proc/sys/fs/binfmt_misc
Gives no error ...and back to prompt immediately

->   ls /proc/sys/fs/binfmt_misc/
Gives now the folowing
register  status

Ok something has been mounted
But this doesn't change anything, and I still get the same error on arm
building …

I see a similar problem on that IRC log :
But it doesn't give an solution (or if it does … please explain …)


Software Engineer
Research Department
Renault Automotive

-- Disclaimer ------------------------------------
Ce message ainsi que les eventuelles pieces jointes constituent une
correspondance privee et confidentielle a l'attention exclusive du destinataire
designe ci-dessus. Si vous n'etes pas le destinataire du present message ou une
personne susceptible de pouvoir le lui delivrer, il vous est signifie que toute
divulgation, distribution ou copie de cette transmission est strictement
interdite. Si vous avez recu ce message par erreur, nous vous remercions d'en
informer l'expediteur par telephone ou de lui retourner le present message,
puis d'effacer immediatement ce message de votre systeme.

*** This e-mail and any attachments is a confidential correspondence intended
only for use of the individual or entity named above. If you are not the
intended recipient or the agent responsible for delivering the message to the
intended recipient, you are hereby notified that any disclosure, distribution
or copying of this communication is strictly prohibited. If you have received
this communication in error, please notify the sender by phone or by replying
this message, and then delete this message from your system.
< Previous Next >