Mailinglist Archive: opensuse-buildservice (225 mails)

< Previous Next >
Re: [opensuse-buildservice] Building KMP packages
2011/9/14 Ann Davis <andavis@xxxxxxxx>:
Hi,

On 9/14/2011 at 09:04 AM, in message
<CAEaLa5EiKCAOEFeGzbRUxw_x5Y5dzK5bCk2bqK7u2TJnXX_8tg@xxxxxxxxxxxxxx>, Ciro
Iriarte <cyruspy@xxxxxxxxx> wrote:
Hi, I'm experimenting with kmp packages,  the thing is that if the
version don't match exactly the version of the kernel I can't load
them...

Current kernel installs modules in /lib/modules/2.6.32.45-0.3-pae, but
my OBS generated kmp puts them in
/lib/modules/2.6.32.45-1-pae/updates. In that situation, modprobe
fails with "ERROR: modinfo: could not find module <name>".

I tought kmp could handle minor version changes in kernel, although in
this case I've built the kmp with that exact same target kernel, OBS
is the one changing the release numbers..

I assume you're building against SLES 11 SP1...?  KMP should be able to
handle this change as long as the symsets required by your KMP are satisfied
by the running kernel.  When the KMP is installed, you should get a
/lib/modules/2.6.32.45-0.3-pae/updates/weak-updates/<driver-name> link that
points to /lib/modules/2.6.32.45-1-pae/updates/<driver-name>.  Do you get
this link?

Regards,

Ann


Yes, I'm recompiling ip_vs included on HAE with latest kernel update
available...

glb1:~ # rpm -ql cluster-network-kmp-pae
/lib/modules/2.6.32.45-1-pae
/lib/modules/2.6.32.45-1-pae/updates
/lib/modules/2.6.32.45-1-pae/updates/ipvs
/lib/modules/2.6.32.45-1-pae/updates/ipvs/ip_vs.ko
/lib/modules/2.6.32.45-1-pae/updates/ipvs/ip_vs_dh.ko
/lib/modules/2.6.32.45-1-pae/updates/ipvs/ip_vs_ftp.ko
/lib/modules/2.6.32.45-1-pae/updates/ipvs/ip_vs_lblc.ko
/lib/modules/2.6.32.45-1-pae/updates/ipvs/ip_vs_lblcr.ko
/lib/modules/2.6.32.45-1-pae/updates/ipvs/ip_vs_lc.ko
/lib/modules/2.6.32.45-1-pae/updates/ipvs/ip_vs_nq.ko
/lib/modules/2.6.32.45-1-pae/updates/ipvs/ip_vs_rr.ko
/lib/modules/2.6.32.45-1-pae/updates/ipvs/ip_vs_sed.ko
/lib/modules/2.6.32.45-1-pae/updates/ipvs/ip_vs_sh.ko
/lib/modules/2.6.32.45-1-pae/updates/ipvs/ip_vs_wlc.ko
/lib/modules/2.6.32.45-1-pae/updates/ipvs/ip_vs_wrr.ko
/lib/modules/2.6.32.45-1-pae/updates/netfilter
/lib/modules/2.6.32.45-1-pae/updates/netfilter/ipt_CLUSTERIP.ko

glb1:~ # find /lib/modules/$(uname -r) -iname "*updates*"
/lib/modules/2.6.32.45-0.3-pae/weak-updates
/lib/modules/2.6.32.45-0.3-pae/weak-updates/updates

There are no links for ip_vs.ko after installing kmp package...


Regards,


--
Ciro Iriarte
http://cyruspy.wordpress.com
--
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References