Mailinglist Archive: opensuse-buildservice (256 mails)

< Previous Next >
Re: [opensuse-buildservice] Unable to connect to API host error
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Mon, 29 Aug 2011 08:24:51 +0200
  • Message-id: <2365206.uUgPIXa0Jz@scherben>
Am Freitag, 26. August 2011, 16:35:57 schrieb Ann Davis:
Hello all,

I'm setting up a new OBS 2.1.11 instance using apache2 w/ vhosts as
specified in
http://gitorious.org/opensuse/build-service/blobs/raw/master/dist/README.SE
TUP . When I access https://localhost , I get the message:

Please use the README.SETUP from 2.1 branch when you setup a 2.1 OBS.
master is for 2.3/2.4 version.

OBS Web Interface Error:
Error Details:
Errorcode: 503
Message: Unable to connect to API host (localhost)

but if I access https://localhost:444 , the OBS API page comes up fine
(after a login prompt). I added the line

You may not have a https setup at all with 2.1 template files.

127.0.0.1 api

to my /etc/hosts file but this doesn't seem to make any difference.

(Note: the
http://gitorious.org/opensuse/build-service/blobs/raw/master/dist/README.SE
TUP differs from the /usr/share/doc/packages/obs-api/README.SETUP installed
by the ops-api package. The one from the package instructs to use lighttpd
instead of apache2. My other OBS 2.1.4 instance is using lighttpd and it's
all working fine.)

Any ideas? Thanks in advance,

Ann
--
Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
References