Mailinglist Archive: opensuse-buildservice (256 mails)

< Previous Next >
Re: [opensuse-buildservice] OBS removes popt-devel from BuildRequires
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Tue, 16 Aug 2011 08:53:04 +0200
  • Message-id: <2397016.nXZxOJuiZg@scherben>
Am Dienstag, 16. August 2011, 15:23:54 schrieb Michal Ludvig:
Hi guys,

I'm trying to build Samba 3.6.0 for CentOS 6 in home:mludvig:samba36.
Unfortunately it's failing because the build system keeps removing
popt-devel from BuildRequires:

I have the following modifications for samba.spec:
64c64
< BuildRequires: autoconf, gawk, gtk2-devel, libcap-devel,
libuuid-devel, popt-devel
---

> BuildRequires: autoconf gawk gtk2-devel libcap-devel libuuid-devel
> popt

Why? Popt-devel rpm is being built from popt package in the same samba36
project and should therefore be available.

Is there anything in the SPEC file that needs fixing? For now it's
pretty much a direct import from CentOS samba src.rpm.

That was a compatibility setting left over from CentOS 5. I have removed it
now, so your package should build now.

--
Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References