Mailinglist Archive: opensuse-buildservice (199 mails)

< Previous Next >
[opensuse-buildservice] Building kiwi images on our own obs instance fails
Hi everyone :)

I've been trying to use our obs instance to build images using kiwi,
unfortunately without any success. I grabbed the sources from the obs
worker appliance from the openSUSE:Tools project [0] and adjusted the
repository paths (obs://openSUSE:Tools/openSUSE_11.3 ->
obs://openSUSE.org:openSUSE:Tools/openSUSE_11.3) but the build fails:

~~~ snip ~~~
+ chroot /usr/src/packages/KIWIROOT-oem /usr/bin/zypper --non-interactive
--no-gpg-checks --reposd-dir /var/cache/kiwi/zypper --cache-dir
/var/cache/kiwi/zypper --raw-cache-dir /var/cache/kiwi/zypper refresh
Repository
'usr_src_packages_SOURCES_repos_openSUSE.org:openSUSE:11.3:Update_standard' is
up to date.
Repository 'usr_src_packages_SOURCES_repos_openSUSE.org:openSUSE:11.3_standard'
is up to date.
Repository
'usr_src_packages_SOURCES_repos_openSUSE.org:openSUSE:Tools_openSUSE_11.3' is
up to date.
All repositories have been refreshed.
+ SPID=7656
+ wait 7656
+ test 0 = 0
+ chroot /usr/src/packages/KIWIROOT-oem /usr/bin/zypper --non-interactive
--no-gpg-checks --reposd-dir /var/cache/kiwi/zypper --cache-dir
/var/cache/kiwi/zypper --raw-cache-dir /var/cache/kiwi/zypper install
--auto-agree-with-licenses --no-recommends OBS-Addon-release adaptec-firmware
atftp bind-libs bind-utils bootsplash bsdtar btrfsprogs db-utils e2fsprogs
elfutils gfxboot glib2-branding-openSUSE grub hdparm hwinfo ifplugd iproute2
iputils kbd kernel-default kernel-default-base kernel-firmware klogd kvm less
lsof lvm2 memtest86+ ncurses-utils ntp obs-worker openSUSE-build-key
openSUSE-release openSUSE-release-mini openslp openssh pam-config procps
qemu-devel strace sysconfig sysfsutils syslog-ng sysstat telnet vim
Loading repository data...
Reading installed packages...
'procps' is already installed.
No update candidate for 'procps-3.2.8-16.1.x86_64'. The highest available
version is already installed.
'ncurses-utils' is already installed.
No update candidate for 'ncurses-utils-5.7-3.39.x86_64'. The highest available
version is already installed.
'openSUSE-release' is already installed.
No update candidate for 'openSUSE-release-11.3-1.82.x86_64'. The highest
available version is already installed.
'openSUSE-release-mini' is already installed.
No update candidate for 'openSUSE-release-mini-11.3-1.82.x86_64'. The highest
available version is already installed.
Resolving package dependencies...

Problem: nothing provides /usr/bin/mimencode needed by
procmail-3.22-246.2.x86_64
Solution 1: do not install sysstat-9.0.4-6.1.x86_64
Solution 2: break procmail by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c): c
+ ECODE=4
+ echo 4
+ exit 4
Jun-22 10:43:46 <1> : EXEC [rm -f
/usr/src/packages/KIWIROOT-oem/screenrc.smart*]
Jun-22 10:43:46 <1> : EXEC [rm -f /usr/src/packages/KIWIROOT-oem/screenrc.ctrls]
failed
Jun-22 10:43:46 <1> : Removing zypper service(s):
usr_src_packages_SOURCES_repos_openSUSE.org:openSUSE:Tools_openSUSE_11.3
usr_src_packages_SOURCES_repos_openSUSE.org:openSUSE:11.3_standard
usr_src_packages_SOURCES_repos_openSUSE.org:openSUSE:11.3:Update_standard
Jun-22 10:43:46 <1> : EXEC [chroot "/usr/src/packages/KIWIROOT-oem" bash -c
"/usr/bin/zypper --non-interactive --no-gpg-checks --reposd-dir
/var/cache/kiwi/zypper --cache-dir /var/cache/kiwi/zypper --raw-cache-dir
/var/cache/kiwi/zypper removerepo
usr_src_packages_SOURCES_repos_openSUSE.org:openSUSE:Tools_openSUSE_11.3 2>&1"]
Jun-22 10:43:46 <1> : EXEC [chroot "/usr/src/packages/KIWIROOT-oem" bash -c
"/usr/bin/zypper --non-interactive --no-gpg-checks --reposd-dir
/var/cache/kiwi/zypper --cache-dir /var/cache/kiwi/zypper --raw-cache-dir
/var/cache/kiwi/zypper removerepo
usr_src_packages_SOURCES_repos_openSUSE.org:openSUSE:11.3_standard 2>&1"]
Jun-22 10:43:46 <1> : EXEC [chroot "/usr/src/packages/KIWIROOT-oem" bash -c
"/usr/bin/zypper --non-interactive --no-gpg-checks --reposd-dir
/var/cache/kiwi/zypper --cache-dir /var/cache/kiwi/zypper --raw-cache-dir
/var/cache/kiwi/zypper removerepo
usr_src_packages_SOURCES_repos_openSUSE.org:openSUSE:11.3:Update_standard 2>&1"]
done
~~~ snip ~~~

And indeed:

$ rpm -qf /usr/bin/mimencode
metamail-2.7.19-1251.1.x86_64
$ find /var/cache/obs/worker/root_1/usr/src/packages/SOURCES/repos -name
metamail*rpm
$

There's a bug report that might describe the very same problem [1]. Any
hints?

Justus

0:
https://build.opensuse.org/package/files?package=OBS-WorkerOnly&project=openSUSE%3ATools
1: https://bugzilla.novell.com/show_bug.cgi?id=515212
--
Justus Winter winter@xxxxxxxxxxxx

PRESENSE Technologies GmbH Sachsenstr. 5, D-20097 HH
USt-IdNr.: DE263765024
Geschäftsführer/Managing Directors AG Hamburg, HRB 107844
Till Dörges Jürgen Sander Axel Theilmann

< Previous Next >
Follow Ups