Mailinglist Archive: opensuse-buildservice (199 mails)

< Previous Next >
Re: [opensuse-buildservice] supporting different versions of a package in one project
Am 21.06.2011 10:57, schrieb Wolfgang Rosenauer:
I have one package in two versions within one project but now I have two
versions of another package where one requires the older version to
build and the other requires the newer version to build.

So I've specified versioned dependencies in BuildRequires but that is
not sufficient. They are actually taken into account but now I get
"unresolvable" for the older package as it doesn't find the previous
version apparently.

I tried to workaround it by disabling "used for build" for the newer
package and retrigger the build of the older dependent package. But it's
still unresolved. Now that is a bug for sure I guess?

Wolfgang
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References