Mailinglist Archive: opensuse-buildservice (199 mails)

< Previous Next >
[opensuse-buildservice] Problem with a package...
Hi all,

I'm having a small issue with one package. I've made a test package on
Banshee:Unstable/banshee with some changes that are required for this
new release of banshee. One of it's dependencies is dbus-sharp-glib
which is provided in the Banshee repository (Banshee:Unstable inherits
those packages to build).

Now I'm facing a very strange issue here... dbus-sharp-glib-devel does
include a Requires in the spec to pull the original package which
provides the libraries... but on OBS builds that package isn't
pulled... And if I enter a BuildRequires: dbus-sharp-glib (to force it
to install that package), the local build works (osc build
Banshee_openSUSE_11.4 --local-package) without issues, but if I commit
it, it fails with this error:

+ exec rpmbuild -ba --define '_srcdefattr (-,root,root)' --define
'disturl
obs://build.opensuse.org/Banshee:Unstable/openSUSE_Factory+Banshee/18969219c66eaf7a3565d33a8b345774-banshee'
/usr/src/packages/SOURCES/banshee.spec
error: Failed build dependencies:
dbus-sharp-glib is needed by banshee-2.1.0-11.1.i586

Anyone has some ideas about this? For some strange reason OBS is
unable to pick up that package.

NM
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages