Mailinglist Archive: opensuse-buildservice (206 mails)

< Previous Next >
Re: [opensuse-buildservice] local OBS server, some glitches and questions
Am Mittwoch, 23. Februar 2011, 10:27:04 schrieb Srinidhi B:
>>> On 2/23/2011 at 01:52 PM, Mathias Homann <admin@xxxxxxxxxx> wrote:
Hi all,

I got my own loacal OBS server up&running but there are still some small
problems...

1. "osc bl" fails to fetch the build log with "Server returned an error:
HTTP
Error 400: Bad Request"

What do you see in api and backend logs?

nothing in backend, api log shows:

192.168.1.7 deepspacetwo.bitcaster.local:81 - [23/Feb/2011:10:35:58 +0100]
"GET /build/Bitcaster/openSUSE_11.2/i586/ffmpeg/_log?start=0&nostream=1
HTTP/1.1" 400 84 "-" "osc/0.129"

webui access to build log works just fine.


2. the download links in the generated .repo files point at the wrong
urls

What do you mean by "wrong urls"? You might want to check if $repodownload
is correctly set in the backend - BSConfig.pm.

checked &corrected that, waiting for builds to finish now... the downloadurl
in the .repo files should be http://hostname:82/projectname/reponame but
instead it is http://hostname/repositories/projectname/reponame



3. packages and repos are not signed

http://en.opensuse.org/openSUSE:Build_Service_Signer

did all that's described in there, no signature on packages...


bye,
MH
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups