Mailinglist Archive: opensuse-buildservice (206 mails)

< Previous Next >
Re: [opensuse-buildservice] Are updates for required packages included in a target?
Am Donnerstag, 10. Februar 2011, 11:51:23 schrieb Andreas.Vetter@xxxxxxxxxx-
wuerzburg.de:
Hi,
What is the policy for updates when building for a target?
E.g. when I build a package that requires openssl, will it be built
against with the GA-shipped version of openssl or against the updated
version of openssl.

By default, you build against the GA version. This is because building
against the updated version may mean that your package would not work with
the GA version anymore. By building against the GA version, your package
should work with all ever released updates for this distro.

The only exception, where binaries are incompatible is the kernel, because
they always change incompatible with any commit (they miss use parts of the
release tag as part of the package version actually).

Is this different for the SLES targets, especially SLES9?
Or do I have to add/link something additionally? If yes, how?
--
Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx
< Previous Next >
References