Mailinglist Archive: opensuse-buildservice (148 mails)

< Previous Next >
Re: [opensuse-buildservice] Re: [Evergreen] [opensuse-packaging] Re: Need help on a Evergreen kernel module
On 1/19/11 12:01 AM, Greg Freemyer wrote:

I'm having a "Out of Memory" error building a package for 11.1 that
should build fine for 11.3.

=== details
I'm still trying to get a clean VirtualBox package to use with Evergreen.

This attempt is to compile VirtualBox-ose from openSUSE11.3 with the 11.1 repo.

I'm pretty sure it worked for both 32bit and 64bit compiles the first
time I tried it. 32bit also worked the second time I tried it, but
64bit has failed twice in a row.

I working in "home:gregfreemyer:Evergreen-11.1> virtualbox-ose"

Looking closer at the last OBS log I see:

[ 1674.366896] Out of memory: Kill process 11317 (cc1plus) score 121
or sacrifice child
[ 1674.366911] Killed process 11317 (cc1plus) total-vm:243020kB,
anon-rss:13640kB, file-rss:268kB

Does anyone have any insight into this?



it is a known issue with OBS and newly deployed build workers which are running a recent snapshot of Factory.

Why run Factory ? Well, it has kernel/xen/kvm fixes (hopefully), which will enable building for Fedora14 among others. But, as Adrian has pointed out to me there are stability issues with them. is the bug I filed a while ago.


To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >