Mailinglist Archive: opensuse-buildservice (148 mails)

< Previous Next >
Re: [opensuse-buildservice] php5 on sles11
Am Samstag, 25. September 2010, 09:36:58 schrieb Marcus Rueckert:
On 2010-09-25 09:02:55 +0200, Marcel Ritter wrote:
Am 25.09.10 00:56, schrieb Peter Bowen:
A recent update to php5 on SLES11 moved from 5.2.6 to 5.2.14. However
builds are still against 5.2.6, meaning all the independent php5-*
packages are still picking up a requirement on php5 = 5.2.6, rendering
them uninstallable. How can we build against 5.2.14 so we get packages
compatible with the updated version?

Hi Peter,

we've got the very same problem, here's the reply
I got from this list on the topic:

--- start quote ---

I just noticed, that SLES 10/11 (latest SP) upgraded the
php5 Version to 5.2.14 - the buildservice still uses older

php versions:
SLES 10 SP3 : 5.2.5
SLES 11 SP1: 5.2.6

Will the updated versions be available in OBS?
Or is there a different repository with latest patches
for SLES (something like "openSUSE:11.3:Update"
in the opensuse world?)

No, there isn't. But SLE updates should stay compatible, so it should
not be a problem to build against the old version. (what is needed
anyway, since SLE updates are optional to install unlike openSUSE).
--- end quote ---

I asked our Novell support engineer about this, and
he agrees about the "should stay compatible" part,
however the php-Macros

Requires: php(zend-abi) = %{php_zend_api}
Requires: php(api) = %{php_core_api}

report changes in the API, so the new packages can no
longer be used (maybe they might work if we ignored
the dependencies, but this will break updates).

I hope there'll be a solution for this problem soon.

this issue is already being worked on.

stay tuned.

What is the current status of this issue?

Thanks,
Holger

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages