Mailinglist Archive: opensuse-buildservice (272 mails)

< Previous Next >
Re: [opensuse-buildservice] How to configure obs-workers to use Xen/KVM?
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Wed, 10 Nov 2010 15:07:19 +0100
  • Message-id: <201011101507.19236.adrian@xxxxxxx>
Am Mittwoch, 10. November 2010, 09:55:10 schrieb Francisco Javier Cuadrado:
Hi, again!

In case you want to use the LVM setup, you can setup these partitions like
described here:

http://en.opensuse.org/openSUSE:Build_Service_Appliance

The obsworker init script will pick automatically partitions which are
named in the /dev/obs/worker_root_? scheme.

Now, I read that article and I've created the following partitions:

/dev/sda1 -> boot
/dev/sda2 -> LVM2
/dev/OBS -> Volume Group
/dev/OBS/root -> root
/dev/OBS/home ->home
/dev/OBS/swap -> swap

These are the basic filesystem structure.

/dev/OBS/worker_root_{1,2} -> My OBS workers' root
/dev/OBS/worker_swap_{1,2} -> My OBS workers' swap

These are the OBS workers' logic volumes.

But OBS workers have failed showing the following log:
http://pastie.org/1281327

Any idea?


Someone from the #opensuse-buildservice IRC channel told me that in
the previous log OBS can't install bash-static and mount-static, then
after installing these packages OBS still fails and now it gives me
the following log: http://pastie.org/1286549

Any idea? It seems that OBS doesn't recognize LVM volume group and
logic volumes.

The binfmt_misc kernel modul seems not to be available.

You may need to add it to your initrd.

--
Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >