Mailinglist Archive: opensuse-buildservice (245 mails)

< Previous Next >
Re: [opensuse-buildservice] Ubuntu 10.10 Repository on build.opensuse.org
  • From: Fritz Elfert <fritz@xxxxxxxxxxxxxxx>
  • Date: Tue, 19 Oct 2010 23:20:36 +0200
  • Message-id: <4CBE0BA4.7020002@xxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 10/19/2010 08:18 PM, Adrian Schröter wrote:
[...]
However trying to build a package seems to fail during the basic build
setup:

Processing triggers for man-db ...
installing procps
update-alternatives: using /usr/bin/w.procps to provide /usr/bin/w (w) 
in auto mode.
start: Unable to connect to Upstart: Failed to connect to socket 
/com/ubuntu/upstart: Connection refused
dpkg: error processing procps (--install):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for man-db ...
Errors were encountered while processing:
 procps
exit ...
System halted.

See the full log at:

https://build.opensuse.org/package/live_build_log?arch=i586&package=libjpeg-turbo&project=home%3Afelfert&repository=Ubuntu_10.10_standard

Anything I can do about that?

Actually yes.

Debug it (via a local build, jumping inside the buildroot and check why the
script is failing).
I suppose it is a missing package, so you can test by adding this missing one
to your prjconf for testing:

osc meta prjconf -e $YOUR_PROJECT

add a line like

Require: missing-package

and tell me which one it was. I simply had no time yet to look inside. By
everybody should be able
to do the debugging as I would do it ;)

thanks
adrian


Well, i'm afraid i'm stuck. (FYI: I'm on FC13, trying a local build for
the first time now ...)

What i've done so far:

- - Installed the build rpm (previously, I used osc remotely only)

- - Tried a local build using the default setup (chrooted build)
Of course, (FC13 uses upstart itself) this gave me completely different
failures, because - even from within the chrooted env - the Ubuntu
upstart binaries seem to connect to the *real* init on my Fedora.

- - Then I tried a kvm type build (FC13 supports kvm out of the box),
stumbled over missing kernel/initrd and tried my regular FC13
kernel/initrd which - almost expected - failed as well. I suspect
missing Fedora specific stuff in the root-FS (got a plymouthd exception).

- - Finally I examined the actual /etc/init/procps.cfg in the buildroot of
the chrooted build and found out, that it merely performs the usual
processing of /etc/sysctl.d/*. Given the facts, that

a) sysctl processing in a chrooted env is quite useless - if not
dangerous for the real system.
b) Most other postinstall scripts silently ignore start failures.
(the cmd in the postinstall usually reads: "start <service> || :")
c) My packages don't need any procps stuff anyway.

I then modified my local _buildinfo-Ubuntu_10.10_standard-i586.xml,
removed the procps dependency and tried a chrooted build again using the
- -o (offline) flag. This time, it successfully built my package.

So, this leaves a few questions:

1. Is it possible to ignore postinstall exit codes for specific
packages in OBS?
2. Is there any chance to get a virtualized build done on any other
host distro than OpenSuSE (In this case: FC13)? If so: any hints.

If 1 == yes, this probably would be the easiest workaround - unless some
build actually requires upstart/sysctl functionality.
If 2 == yes, this would enable me to actually do proper debugging ;)

Cheers
-Fritz
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org/

iEYEARECAAYFAky+C58ACgkQboM4mAMyprAtbgCdF6LKckd5iVEYG7ghfzzr/Oi/
LRQAn2XNr2zSU005wugSbdmJwV3MyMvI
=gLo6
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups