Mailinglist Archive: opensuse-buildservice (245 mails)

< Previous Next >
[opensuse-buildservice] Dependency problem on opensuse factory
  • From: <a.cavallo@xxxxxxxxxxxxx>
  • Date: Thu, 14 Oct 2010 12:07:22 +0200
  • Message-id: <11931.1287050842@xxxxxxxxxxxxx>
Hi,

I'm working on a little project on the suse build service:

home:cavallo71:opt-python-interpreters
opt-python-svn85227

This is a special /opt based python version pulled from the
svn repository: it is based on python 2.7.x (so it carries its own
libpython2.7.so.1.0).

On a OpenSuSE factory the virtual machine build process pulls the initial
dependency list including libpython2.7.so.1.0: this is available both from
the (I suppose) base distro and from mine /opt based repository (there are
multiple opt-python-svnXXXXX one for each subversion checkout).

This will return the following error message:

"have choice for libpython2.7.so.1.0 needed by python-base:
opt-python-svn84368
opt-python opt-python-svn84091 opt-python- svn83620 opt-python-svn83132
opt-python-svn84276 libpython2_7-1_0"

The build fails since few days ago, so I suppose something has changed
in the repos resolution order recently.

Thanks,
Antonio Cavallo


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages