Mailinglist Archive: opensuse-buildservice (258 mails)

< Previous Next >
Re: [opensuse-buildservice] Linking two (private) OBS servers at different sites.
  • From: Troy Telford <ttelford.groups@xxxxxxxxx>
  • Date: Wed, 11 Aug 2010 11:59:47 -0600
  • Message-id: <201008111159.47890.ttelford.groups@xxxxxxxxx>
On Tuesday, August 10, 2010 03:29:33 am Adrian Schröter wrote:
However, if I look in /srv/obs/log/scheduler_arch.log, I see the
following repeated endlessly:

2010-08-09 19:02:13: waiting for an event...
retrying watcher for http://obsapi.foo.bar.com/public
setting up watcher for http://obsapi.foo.bar.com/public
2010-08-09 19:03:16: waiting for an event...
response from watcher for http://obsapi.foo.bar.com/public
400 remote error: Bad Request
retrying in 60 seconds

Any ideas on what I might be missing?

Not really, I would either add some debug code to print the request or look
in the logs of the remote instance.

You need to enable anonymous access.
Otherwise, the API will reject everything w/o an auth.

Erm, no, anonymous access is only for webui. /public is independend of
that.

Unfortunately, the log is as follows (each time it fails):
::ffff:128.162.244.210 obsapi.foo.bar.com - [11/Aug/2010:11:42:32 -0600] "POST
/public/lastevents HTTP/1.1" 400 154 "-" "BSRPC 0.9.1"

And I'm not sure where in the code to add any debugging...
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups