Mailinglist Archive: opensuse-buildservice (258 mails)

< Previous Next >
Re: [opensuse-buildservice] Error in osc; checkin doesn't run (SOLVED)
  • From: "Sascha 'saigkill' Manns" <samannsml@xxxxxxxxxxxxx>
  • Date: Fri, 6 Aug 2010 18:25:49 +0200
  • Message-id: <201008061826.08033@xxxxxxxxxxxxxxxxxxx>
Am Freitag, 6. August 2010 18:17:30 wrote Dominique Leuenberger:
On 08/06/2010 at 6:11 PM, "Sascha 'saigkill' Manns"
<samannsml@xxxxxxxxxxxxx>

Make sure you DO have a Summary: field in your preamble... it's
stopping you from uploading a spec file that would focribly bring
the build to a failure anyway (rpm will just complain about it
during the build).

Yes i have a Summary Field in my header. I've attached my actual
spec File. Maybe you find the error. I've tested different things,
but nothing works...

just a blind guess (did not test anything): the validator probably
get's confused by the macro in the middle of the preamble
(%kde4_runtime_requires)

I doubt the validator can expand this macro and as such has no clue
if the preamble continues after or not...

Did you try moving Summary higher up, like to the Name / Version
(where I would expect to see it anyhow :) ) ?
Cool that works :-) Thanks a lot :-))

--
Sincerely yours

Sascha Manns
open-slx GmbH
openSUSE Community & Support Agent
openSUSE Marketing Team

Blog: http://saigkill.wordpress.com

Web: http://www.open-slx.de (openSUSE Box Support German)
Web: http://www.open-slx.com (openSUSE Box Support English)
< Previous Next >