Mailinglist Archive: opensuse-buildservice (258 mails)

< Previous Next >
Re: [opensuse-buildservice] 'clicfs' not found / kiwi
  • From: Javier Llorente <javier@xxxxxxxxxxxx>
  • Date: Fri, 6 Aug 2010 00:18:45 +0200
  • Message-id: <201008060018.46087.javier@xxxxxxxxxxxx>
On Jueves, 5 de Agosto de 2010 09:36:43 Adrian Schröter escribió:
On Thursday 05 August 2010 00:29:39 Javier Llorente wrote:
Hi Adrian,

On Miércoles, 4 de Agosto de 2010 10:01:20 usted escribió:
On Tuesday 03 August 2010 00:35:59 Javier Llorente wrote:
Hello listmates,

I am trying to build a 11.2-based OEM image on the Build Service and
I am getting the following error:

'clicfs' not found.


https://build.opensuse.org/package/live_build_log?arch=x86_64&package=ope

n- pc-image&project=spins%3Aopen-
pc%3Aimages&repository=images

How can I add it to my kiwi build environment?

In general you can add it to your local prjconf, but this one should be
there already.

We have a

Substitute: kiwi-boot:isoboot kiwi-desc-isoboot module-init-tools
elfutils

squashfs clicfs

in our 11.2 configuration. Or do you use some other repos which
overwrite it ?

I used the default settings. I have added the "substitute line" but still
complains about clicfs .

I don't know if it's related, but kiwi 3.74 doesn't have clicfs as a
dependency. https://bugzilla.novell.com/show_bug.cgi?id=573357

yes, that is kind of nasty, but has a reason. Because you can install kiwi
on system X and build an image to system Y it does not help much to add a
requires.

Looks like you use the new kiwi and new clicfs. Now "adaptec-firmware" is
lacking.

I will copy a kiwi version later on to openSUSE:Tools and adapt all the
needed prjconf settings there. (I can't do that in plain openSUSE:11.2,
because that comes with a different version of kiwi).

Or shall we maintain the prjconf settings in Virtualization:Appliances
project? Marcus, do you have an opinion here ?


Thanks for your help, Adrian.

I have adapted the kiwi recipe and packages to openSUSE 11.3, tried to build
the image (without the Virtualization:Appliances repo) and I got the following
error:

'squashfs' not found in package names. Trying capabilities.
No provider of 'squashfs' found.
'adaptec-firmware' not found in package names. Trying capabilities.
No provider of 'adaptec-firmware' found.
'atftp' not found in package names. Trying capabilities.
No provider of 'atftp' found.
'fbiterm' not found in package names. Trying capabilities.
No provider of 'fbiterm' found.
'fribidi' not found in package names. Trying capabilities.
No provider of 'fribidi' found.
'kernel-desktop' not found in package names. Trying capabilities.
No provider of 'kernel-desktop' found.

Full log available at:
https://build.opensuse.org/package/live_build_log?arch=x86_64&package=open-
pc-factory&project=spins%3Aopen-pc%3Aimages&repository=images


Cheers,
--
Javier Llorente
< Previous Next >