Mailinglist Archive: opensuse-buildservice (332 mails)

< Previous Next >
Re: [opensuse-buildservice] Requires(pre): problem
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Thu, 1 Jul 2010 08:09:23 +0200
  • Message-id: <201007010809.23590.adrian@xxxxxxx>
On Wednesday 30 June 2010 23:21:06 John Beranek wrote:
This evening I created a new package "nagios" in
home:johnberanek:nagios3. This was an import of a package from EPEL6.

As received from EPEL6 it builds happily on a CentOS 5 machine, but in
OBS with RHEL5/CentOS5 build target it fails with "unresolvable: nothing
provides user(nagios), group(nagios)".

The package spec has:

Requires: user(nagios)
Requires(pre): user(nagios)
Requires: group(nagios)
Requires(pre): group(nagios)

Provides: user(nagios)
Provides: group(nagios)

On the advice of darix/coolo I solved the problem with a bootstrap
procedure of commenting out the Requires(pre) lines, and this allows the
build to complete. At this point I should be possible to put the
Requires(pre) lines back.

However, that bootstrap hack is hardly obvious/"nice" behaviour for OBS. ;)

Right, that's all for now.

Can you explain why you need to state that your package needs itself ?

What else should OBS do in this case ?

bye
adrian

--

Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups