Mailinglist Archive: opensuse-buildservice (348 mails)

< Previous Next >
Re: [opensuse-buildservice] Problem building on 'SLES 10 i586'
  • From: Danilo Godec <danilo.godec@xxxxxxxxx>
  • Date: Thu, 15 Apr 2010 16:11:55 +0200
  • Message-id: <4BC71EAB.5050504@xxxxxxxxx>
On 15. 04. 2010 13:51, Marcus Meissner wrote:
On Thu, Apr 15, 2010 at 01:28:48PM +0200, Danilo Godec wrote:

Hello,

I have a couple of packages in my home project, that never get built for
SLES 10 i586.

The errors are similar for various packages:

package 'ucarp':

expansion error - nothing provides libcrypto.so.0.9.8 needed by
pwdutils, nothing provides libssl.so.0.9.8 needed by pwdutils, nothing
provides libcrypto.so.0.9.8 needed by bind-libs, nothing provides
libcrypto.so.0.9.8 needed by bind-utils, nothing provides
libcrypto.so.0.9.8 needed by openldap2-client, nothing provides
libssl.so.0.9.8 needed by openldap2-client

package 'openswan':

expansion error nothing provides openssl = 0.9.8a needed by
openssl-devel, nothing provides libcrypto.so.0.9.8 needed by curl,
nothing provides libssl.so.0.9.8 needed by curl

package 'l2tpd':

expansion error nothing provides libcrypto.so.0.9.8 needed by
pwdutils, nothing provides libssl.so.0.9.8 needed by pwdutils, nothing
provides libcrypto.so.0.9.8 needed by bind-libs, nothing provides
libcrypto.so.0.9.8 needed by bind-utils, nothing provides
libcrypto.so.0.9.8 needed by openldap2-client, nothing provides
libssl.so.0.9.8 needed by openldap2-client


package 'AFBackup':

expansion error nothing provides libcrypto.so.0.9.8 needed by
pwdutils, nothing provides libssl.so.0.9.8 needed by pwdutils, nothing
provides libcrypto.so.0.9.8 needed by bind-libs, nothing provides
libcrypto.so.0.9.8 needed by bind-utils, nothing provides
libcrypto.so.0.9.8 needed by openldap2-client, nothing provides
libssl.so.0.9.8 needed by openldap2-client

Some other packages build nicely (nuttc, unrtf, pflogsumm).

It seems there is a problem with 'openssl', but only for SLES 10 i586 ...

Do you have your own openssl package in there?


Yes! That was the problem... I don't even remember why I needed the
'openssl-1.0.0-beta2'.

Is there a way to tell the build service to use packages from the
'standard' repository?

Which is the home user reponame?


home:danci1973


Thanks, Danilo


--
Danilo Godec, sistemska podpora / system administration

Predlog! Obiscite prenovljeno spletno stran www.agenda.si

ODPRTA KODA IN LINUX
STORITVE : POSLOVNE RESITVE : UPRAVLJANJE IT : INFRASTRUKTURA IT :
IZOBRAZEVANJE : PROGRAMSKA OPREMA

Visit our updated web page at www.agenda.si

OPEN SOURCE AND LINUX
SERVICES : BUSINESS SOLUTIONS : IT MANAGEMENT : IT INFRASTRUCTURE : TRAINING :
SOFTWARE

begin:vcard
fn:Danilo Godec
n:Godec;Danilo
org:Agenda OpenSystems
adr:;;Pohorskega bataljona 49;Maribor;;2000;Slovenia
email;internet:danilo.godec@xxxxxxxxx
url:http://www.agenda.si/
version:2.1
end:vcard

< Previous Next >
Follow Ups