Mailinglist Archive: opensuse-buildservice (216 mails)

< Previous Next >
Re: [opensuse-buildservice] Mandriva build failures
  • From: John Beranek <john@xxxxxxxxxxxx>
  • Date: Tue, 23 Mar 2010 13:37:40 +0000
  • Message-id: <4BA8C424.50600@xxxxxxxxxxxx>
On 23/03/10 10:00, Lubos Lunak wrote:
On Tuesday 23 of March 2010, John Beranek wrote:
A package that has built perfectly in the past has stopped building for
Mandriva distributions. I don't understand how it's failing.

The package in question is 'xdiskusage' in the 'home:johnberanek'
project. Builds for the following distros are failing:

Mandriva_2009.1
Mandriva_2010

The errors being of the form:

libxinerama1-devel is needed by xdiskusage-1.48.1-7.1.src

I think OBS doesn't handle %{mdkversion} when parsing BuildRequires,
only %{mandriva_version}. Probably worth a bugreport, if that is the case.

Many thanks! That does appear to be the problem. Using mandriva_version
instead does indeed fix it.

I will file a bug report.

Cheers,

John.

P.S. Now onto getting ftlk compiling for all the distros again, the
project I had linked to has gone away :(

--
John Beranek To generalise is to be an idiot.
http://redux.org.uk/ -- William Blake

< Previous Next >
Follow Ups